Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×


Join Truck Conversion Today
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
 
Old 11-09-2023, 11:00 PM   #1
cjc
Member
 
Join Date: Jan 2004
Location: Cape Coral, Florida, USA
Posts: 53
Default Code reader

It's been 20 years and 155,000 miles trouble free with the 2003 Freightliner Columbia with a Mercedes MBE4000. It's throwing a code, but I don't have a reader to check it out. Does anyone have a source for a code reader for this engine? It only happens at start up and maybe lasts 15 or 20 minutes driving down the road. The check engine light randomly flashes, but not like it's a number code unless there are a bunch of them and I'm missing the count. There are no other signs of engine issues. Engine runs fine, Meritor tyranny shifts like it always did. After 15, 20 minutes down the road, the flashing stops and all is well. I was thinking maybe it had something to do with a coolant level or some other fluid, but everything is good. Any ideas on what's happening or a code reader? Thanks.
cjc is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:04 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
×