Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×


Join Truck Conversion Today
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
 
Old 01-15-2024, 02:29 PM   #1
Member
 
Join Date: Oct 2016
Location: Thibodaux
Posts: 46
Default 2005 FL 120 Dash died

My dash is dead. Starts normally, runs just fine, etc. but no cycling of the dash instruments with the key on, and all are pegged at "0" after start-up. My ScanGaugeD gives me the temps, voltage, etc. Might be coincidental but I also have a "254 12 0" code which points to a fuel sensor or some such. The fuel filter glass dome is pegged at the top so that might be the reason for that code.

The MMDC box photo is attached and it does not look happy. An online search suggested that this is a common fault and the elec connectors on the MMDC could be corroded as well as the connectors running to all the other instrument gauges.

The truck lives in a hot and humid swamp and, has not been run in the last several months. I normally am on the road every 3 months or so the truck is mad at me?

Any help will be appreciated.
Attached Thumbnails
IMG_0616.jpg   IMG_0617.jpg   IMG_0618.jpg  
__________________
2005 FL Elite, Detroit, twin screw, 10spd Man
ItalGerBrit is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:59 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
×