Join Truck Conversion Today
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
 
Old 02-11-2015, 01:40 PM   #1
Junior Member
 
Join Date: Jul 2012
Posts: 18
Default Volvo help!

I have been chasing a problem with our 1994 WIA with a VED12 for two years now. Driviong along, everything good and then it just shuts off, 99% of the time I can just cycle the key and it will take off again. May happen every 100 feet, may happen in 100 miles or may not happen at all. I used to think the ECM was losing power for a moment but cycling the key would not fix this I think. The only codes it stores is 31-36, injector failures. This thing is parked on my last nerve and I'm out of ideas. I'm hoping an old school Volvo tech could chime in and point me in the right direction. ANY help appreciated........-Curtis
__________________

SnaykeByte is offline   Reply With Quote
Old 02-13-2015, 05:14 PM   #2
Junior Member
 
Join Date: Jul 2012
Posts: 18
Default

Oh come on now, 36 views and not one idea???
__________________

SnaykeByte is offline   Reply With Quote
Old 02-13-2015, 08:09 PM   #3
Senior Member
 
Join Date: Oct 2014
Location: Where my trailer is sitting!
Posts: 251
Default

Electronic injectors? If so with the injector codes I would be looking at the harness for them. Other than that I have no idea....
__________________
For now 1996 Dodge Ram 5.9 Cummins 365HP 830TQ pulling a 2006 28' Dutchmen Fifthwheel and at times a 16' boat behind that!
Mntom is offline   Reply With Quote
Old 02-13-2015, 10:56 PM   #4
Senior Member
 
Join Date: Jan 2011
Posts: 527
Default

I'm no help, I'm a gas motor guy. I say check the ignition and spark plugs... lol.
hot rod is offline   Reply With Quote
Old 02-14-2015, 02:49 PM   #5
Junior Member
 
dvision's Avatar
 
Join Date: Jan 2013
Location: Central Iowa
Posts: 21
Default .

What kind of motor? I had a Cummins that had an electrical bug I was not ever able to find. Finally sold that POS. Another truck I still have has the Detroit and we had a problem with the ground to the ECM. It would die without warning and then start right back up. Might be a place to start.
dvision is offline   Reply With Quote
Old 02-14-2015, 06:29 PM   #6
Senior Member
 
Join Date: Dec 2003
Location: Grand Forks BC Canada
Posts: 167
Default

As a retired mechanic, I have run into intermittent problems my whole career. Unless I was there for when it showed up the chances of finding the problem were fairly remote.
I would be wary of driving this if it quits while on the road.
My thoughts are to phone other Volvo dealers or go on a Volvo forum and try to find a solution before someone gets hurt.
Good luck
Gordy is offline   Reply With Quote
Old 02-14-2015, 08:03 PM   #7
Junior Member
 
Join Date: Jul 2012
Posts: 18
Default

Volvo VED12
SnaykeByte is offline   Reply With Quote
Old 02-14-2015, 08:07 PM   #8
Junior Member
 
Join Date: Jul 2012
Posts: 18
Default

Quote:
Originally Posted by Gordy View Post
As a retired mechanic, I have run into intermittent problems my whole career. Unless I was there for when it showed up the chances of finding the problem were fairly remote.
I would be wary of driving this if it quits while on the road.
My thoughts are to phone other Volvo dealers or go on a Volvo forum and try to find a solution before someone gets hurt.
Good luck

Thank you for the advise, but like I said I have chased this problem for two years with no appreciable progress. I too am a retired master tech and I just shut my shop down after 25 years, I figured that was long enough. I have had it to five Volve truck shops and spent considerable cabbage to have it diagnosed with no results.
SnaykeByte is offline   Reply With Quote
Old 02-15-2015, 09:24 PM   #9
Senior Member
 
Join Date: Dec 2003
Location: Grand Forks BC Canada
Posts: 167
Default

I Googled Volvo VED12 shutdown and there is some info available online. Of course it is vague but it may give you some other ideas other than what has been tried.
Good luck
Gordy is offline   Reply With Quote
Old 02-15-2015, 11:01 PM   #10
Junior Member
 
Join Date: Jul 2012
Posts: 18
Default

Soooooo, send me a link
SnaykeByte is offline   Reply With Quote
Old 02-16-2015, 02:30 AM   #11
Senior Member
 
bushpilot's Avatar
 
Join Date: Jul 2011
Location: Tomball
Posts: 1,414
Default

Quote:
Originally Posted by SnaykeByte View Post
Soooooo, send me a link
Click here --> Google Search Link
__________________
Don R.
'04 Haulmark (M42386) 42', 2 slide, 10kw - Pictures
'04 F350 CrewCab Longbed 4x4, 50g aux tank & gear vendors dbl over
bushpilot is offline   Reply With Quote
Old 02-17-2015, 07:09 PM   #12
Junior Member
 
Join Date: Jul 2012
Posts: 18
Default

Have already read most of those posts, I preciate the input anyway.
SnaykeByte is offline   Reply With Quote
Old 06-24-2015, 10:48 PM   #13
Junior Member
 
Join Date: Jul 2012
Posts: 18
Default

Nevermind I figured it out.
SnaykeByte is offline   Reply With Quote
Old 06-25-2015, 10:02 AM   #14
Senior Member
 
Join Date: Oct 2014
Location: Where my trailer is sitting!
Posts: 251
Default

So, what did you find?
__________________
For now 1996 Dodge Ram 5.9 Cummins 365HP 830TQ pulling a 2006 28' Dutchmen Fifthwheel and at times a 16' boat behind that!
Mntom is offline   Reply With Quote
Old 06-25-2015, 07:40 PM   #15
Member
 
jasong's Avatar
 
Join Date: May 2015
Location: Full time on the road
Posts: 71
Default

Quote:
Originally Posted by SnaykeByte View Post
Nevermind I figured it out.
.......aaaaand ?
jasong is offline   Reply With Quote
Old 06-25-2015, 09:09 PM   #16
Junior Member
 
Join Date: Jul 2012
Posts: 18
Default

Idioticly done butt connector in wire that grounds ECM pulled across transmission, almost impossible to find.
SnaykeByte is offline   Reply With Quote
Old 06-26-2015, 09:50 AM   #17
Senior Member
 
Join Date: Oct 2014
Location: Where my trailer is sitting!
Posts: 251
Default

So, did you stumble across it? It's amazing how something so small can do so much........
__________________

__________________
For now 1996 Dodge Ram 5.9 Cummins 365HP 830TQ pulling a 2006 28' Dutchmen Fifthwheel and at times a 16' boat behind that!
Mntom is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:20 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×