Join Truck Conversion Today
Reply
 
LinkBack Thread Tools Display Modes
 
Old 06-09-2016, 11:28 PM   #1
Senior Member
 
Join Date: Mar 2015
Location: Cincinnati
Posts: 143
Default My BR Slide Controller Burned Up, But Not MH

On a trip few weekends ago, I was outside setting things up and wife was inside running the slides out. BR slide moved out and must have got a stuck relay or something. The Intellitec Slide Control Box overheated and partially melted, fortunately was no fire or damage to other components. I thought I smelled a funny burned plastic smell in the BR, but could not figure out the source while we were camping. Upon packing up, the slide would not move in, I had to manually crank it in.

Once home I was able to do some investigation and found this:





and inside the box:



I was able to get a new slide controller, nothing $100 can't fix. I put some new wire ends to replace the burnt ones, connected it up and now the slide works like it is supposed to. I feel fortunate that it was just this and not a more significant problem or fire.

Just to make it a nicer posting, here is the view from the campsite we were at down at Elephant Butte State Park in southern NM, just north of Truth or Consequences, NM. EBSP is the largest lake in NM, made by dam on the Rio Grande River to form the lake.

__________________

__________________
2005 Kenworth Showhauler 45 ft total length
twin screw, 450 hp ISX, 10 speed Ultrashift
38Chevy454 is offline   Reply With Quote
Old 06-10-2016, 08:30 AM   #2
Senior Member
 
Join Date: Oct 2014
Location: Where my trailer is sitting!
Posts: 251
Default

I don't see any pictures........
__________________

__________________
For now 1996 Dodge Ram 5.9 Cummins 365HP 830TQ pulling a 2006 28' Dutchmen Fifthwheel and at times a 16' boat behind that!
Mntom is offline   Reply With Quote
Old 06-10-2016, 09:25 AM   #3
Senior Member
 
Join Date: Mar 2015
Location: Cincinnati
Posts: 143
Default

Quote:
Originally Posted by Mntom View Post
I don't see any pictures........
No? They are linked to my photobucket acct and should work for all to see. Anyone else have trouble?
__________________
2005 Kenworth Showhauler 45 ft total length
twin screw, 450 hp ISX, 10 speed Ultrashift
38Chevy454 is offline   Reply With Quote
Old 06-10-2016, 09:30 AM   #4
Senior Member
 
Join Date: Oct 2014
Location: Where my trailer is sitting!
Posts: 251
Default

Quote:
Originally Posted by 38Chevy454 View Post
No? They are linked to my photobucket acct and should work for all to see. Anyone else have trouble?
OK, now they show up....... Dang, I hate when these things screw up.
Anyhow, looks like you got quite lucky! I can see things going up in smoke with the problem you had.
__________________
For now 1996 Dodge Ram 5.9 Cummins 365HP 830TQ pulling a 2006 28' Dutchmen Fifthwheel and at times a 16' boat behind that!
Mntom is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:01 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.